NOP MOD Player v2.0

Page 10/12
3 | 4 | 5 | 6 | 7 | 8 | 9 | | 11 | 12

By knm1983

Hero (566)

knm1983's picture

24-04-2020, 14:18

Now after continuing the load of the playlist it freezes in the 8 music.
I think it is random.

By Latok

msx guru (3866)

Latok's picture

24-04-2020, 15:11

SjaaQ wrote:
Manuel wrote:

... long story...

When testing I never saw any flag raised. In blueMSX, I saw this flag raised like expected.

To make a long story short, Turbo-R users should disable R800 mode until I get the chance to test on real hardware.Which is probably never going to happen. There is no way for me to troubleshoot the issue at this point.

Then I suggest your program does so after detecting a turboR Smile

By SjaaQ

Champion (266)

SjaaQ's picture

24-04-2020, 15:23

@knm1983 could you test 1845 and report the color when it freezes? I have isolated "red" as beeing the loading function and move the colors to this function only.

By SjaaQ

Champion (266)

SjaaQ's picture

24-04-2020, 15:24

Latok wrote:

Then I suggest your program does so after detecting a turboR Smile

Meh. Don't want to enforce settings users can manage themselves.

By Latok

msx guru (3866)

Latok's picture

24-04-2020, 15:38

People dont read manuals. So there will be many freezes on turboR if you don't. But hey, only a suggestion.Its your party and its a great one!

By SjaaQ

Champion (266)

SjaaQ's picture

24-04-2020, 15:44

This was not about the freezes, but the timing that screws up the notes.

I am looking into the freezes, but cannot reproduce it so far.

By knm1983

Hero (566)

knm1983's picture

24-04-2020, 17:16

ok SjaaQ then I will test the new version and report

By SjaaQ

Champion (266)

SjaaQ's picture

24-04-2020, 18:41

knm1983 wrote:

Hello again SjaaQ.
I have uploaded two new MP3s in the drive directory with the SPACEDEB music, it seems that some note of the music sounds strange in position 4 to 7 of channel 4.

Fixed in Build: 1853. Seems I forgot to use the high nibble sample id when looking up finetunes. Good job in reporting this one!

By knm1983

Hero (566)

knm1983's picture

24-04-2020, 18:50

Ohhh little by little you are solving the problems, I am very happy to help you

Thanks , I have downloaded the new version to test Smile

By SjaaQ

Champion (266)

SjaaQ's picture

24-04-2020, 18:53

1853 has another issue. Use 1855 instead.

Page 10/12
3 | 4 | 5 | 6 | 7 | 8 | 9 | | 11 | 12