help openmsx debugger

Page 5/7
1 | 2 | 3 | 4 | | 6 | 7

By manolito74

Paragon (1184)

manolito74's picture

03-10-2020, 15:53

I see that it is only a problem mine because there are also another threads with people talking and having the same problem. :-(

By manolito74

Paragon (1184)

manolito74's picture

03-10-2020, 17:34

I wanted to say: "I see that it is NOT ONLY a problema mine..." ;-)

By Manuel

Ascended (17499)

Manuel's picture

03-10-2020, 20:23

Question is what is different between your system and systems where it does work normally.

By manolito74

Paragon (1184)

manolito74's picture

03-10-2020, 20:36

If my case was an isolated case... it would be obvious that it would be my System Fault... but as you can see there are more "exceptions"... so perhaps and only perhaps... could be a remote possibility that your Soft can have a bug or something that causes this problem and we haven't discoverted that til the moment... ;-)

https://www.msx.org/forum/msx-talk/openmsx/debugger-cant-fin...

By manolito74

Paragon (1184)

manolito74's picture

03-10-2020, 23:03

I see you talk about, and recognize, that there was a bug, here:

https://www.msx.org/forum/msx-talk/emulation/to-manuel-openm...

But the last link https://openmsx.vampier.net/openMSX_Debugger_x64_20180514.zip doesn't work. :-(

Gracias & Saludetes. ;-)

By Manuel

Ascended (17499)

Manuel's picture

03-10-2020, 23:27

My point was that we must find out the difference between working and non-working systems to get a clue. I have no clue at the moment.

By Manuel

Ascended (17499)

Manuel's picture

03-10-2020, 23:33

Perhaps it's due to that version being different indeed. That particular build was "270". The source code is at "282".

So, we could use a fresh new build of the debugger for Windows. Who can build it?

By brawaga

Resident (39)

brawaga's picture

02-01-2021, 12:35

How can I attach back all tool windows listed in View menu? Or maybe there's a config file I can delete to reset its configuration?

By AxelF

Champion (373)

AxelF's picture

02-01-2021, 13:27

You can drag it back to the debugger window somehow, I never got that to work.
That is why i delete all items in the following Windows registry to reset the layout.
Computer\HKEY_USERS\S-1-5-21-102739037-420274057-1067389056-500\SOFTWARE\openMSX\debugger\Layout
-WidgetLayout
-WindowGeometry

By Daemos

Paragon (1793)

Daemos's picture

02-01-2021, 14:03

Once you manage to drag some window out of the debugger you are doomed. I then delete all the config files to get it back.

In linux I have no clue where it stores its settings. Still eager to find out. Propably in the .openMSX folder. I should check the sources.

Page 5/7
1 | 2 | 3 | 4 | | 6 | 7