help openmsx debugger

Page 7/7
1 | 2 | 3 | 4 | 5 | 6 |

By Manuel

Ascended (17499)

Manuel's picture

09-01-2021, 19:55

I can't claim it's flawless, but this is what it is now and this is how you can get your floating windows back into the dock.

Patches to improve it are most welcome.

By brawaga

Resident (39)

brawaga's picture

15-01-2021, 16:13

Manuel wrote:

Small demo here: https://www.youtube.com/watch?v=zeUK83nSlfw

Great, Manuel. Unfortunately, I have no that area on the right. To understand what I am saying, try to detach all of the tool windows and then attach all of them back.

By Manuel

Ascended (17499)

Manuel's picture

16-01-2021, 00:37

It's possible: drag as I showed to the top right of the Code view, and then go right of the window. There it will snap. See https://youtu.be/Lin9DNinnQc

By Daemos

Paragon (1793)

Daemos's picture

16-01-2021, 19:48

I tried on the linux version without luck. My debugger is doomed now Wink

However after fiddling around long enough I figured that your must grab the window on the inside and not by the title bar. I snapped it back!

By Manuel

Ascended (17499)

Manuel's picture

16-01-2021, 20:19

Yeah, that's what I said... several times Tongue

By geijoenr

Master (205)

geijoenr's picture

16-01-2021, 20:49

very user friendly interface, haha

By Manuel

Ascended (17499)

Manuel's picture

16-01-2021, 21:56

As I said: it's not flawless. I guess it turned out less friendly than intended, but it was hardly changed after it was added here in 2007: https://github.com/openMSX/debugger/commit/1faeec2ca44bf69da...
Again: patches most welcome.

By brawaga

Resident (39)

brawaga's picture

18-01-2021, 12:49

Ok, finally I managed to attach some of them. As I see, we can only attach to window border if attached border is on it also, so if there is empty place, impossible to put something there.
We can ignore that attachment appears at different place first time, that is relatively harmless.
But I spent an hour trying to make a configuration near to what it was, but simply unable to put them in just in any meaningful way, it is just a mess of rectangles hardly fitting into the screen with a most of window space unused. Otherwise they do not attach.
Also, code view and stack view do not autosize anymore.
There MUST be configuration file to delete for turning back to defaults.

By FiXato

Scribe (1694)

FiXato's picture

18-01-2021, 14:54

Not sure where it's stored on other systems, but under Windows you can follow AxelF's instructions to find the registry keys:

AxelF wrote:

You can drag it back to the debugger window somehow, I never got that to work.
That is why i delete all items in the following Windows registry to reset the layout.
Computer\HKEY_USERS\S-1-5-21-102739037-420274057-1067389056-500\SOFTWARE\openMSX\debugger\Layout
-WidgetLayout
-WindowGeometry

Page 7/7
1 | 2 | 3 | 4 | 5 | 6 |