help openmsx debugger

Page 8/8
1 | 2 | 3 | 4 | 5 | 6 | 7 |

By Francisco Gálvez

Resident (36)

Francisco Gálvez's picture

24-04-2021, 13:25

Hi folks...
My name is Paco. I write from Seville (Spain). I'm trying to leave windows and use only linux (I'm using linux Mint).
I already installed OpenMSX 16 and catapult.
I'm having problems with the debugger.

Unzipping in documents I tried the make command and I got:

root@porlatillinux:/home/paco/Documentos/debugger-master# make
Up to date: derived/config/Version.ii
Compiling CPURegsViewer.cpp...
src/CPURegsViewer.cpp: In member function ‘virtual void CPURegsViewer::paintEvent(QPaintEvent*)’:
src/CPURegsViewer.cpp:41:31: error: ‘class QFontMetrics’ has no member named ‘horizontalAdvance’
  int regWidth = fontMetrics().horizontalAdvance("HLW");
                               ^~~~~~~~~~~~~~~~~
src/CPURegsViewer.cpp:42:31: error: ‘class QFontMetrics’ has no member named ‘horizontalAdvance’
  int valWidth = fontMetrics().horizontalAdvance("FFFFWW");
                               ^~~~~~~~~~~~~~~~~
src/CPURegsViewer.cpp: In member function ‘virtual QSize CPURegsViewer::sizeHint() const’:
src/CPURegsViewer.cpp:83:37: error: ‘class QFontMetrics’ has no member named ‘horizontalAdva
....

Any Idea to solve it please? ... I tried to install Qt5.12 and Qt6

I've been searching for a workaround without sucess..

Any help is welcome.

Thanks in advance

By Manuel

Ascended (17877)

Manuel's picture

24-04-2021, 16:10

I think the debugger is available as a package in Linux Mint. Try to install openmsx-debugger. At least it's available in Debian, so I suppose also in Mint.
On Debian I can compile it fine with Qt 5.15.

By Francisco Gálvez

Resident (36)

Francisco Gálvez's picture

25-04-2021, 15:42

Hi Manuel...
It worked but not as I expected.. I installed the openmsx 16 version but the debugger install automatically the 14 version and only connect with that version.
I don't find a way to connect de debugger to the version I installed.
I'll try to figure it out before use wine.
Thank you very much anyway.

By Manuel

Ascended (17877)

Manuel's picture

25-04-2021, 18:16

There should be no need to use wine at all. This software is developed on Linux... would be absurd to run it in wine to make it work on Linux Smile

What exactly is going wrong then? Older debuggers should connect fine to newer openMSX versions. There is no check on version.

By Francisco Gálvez

Resident (36)

Francisco Gálvez's picture

25-04-2021, 21:00

Hi... Thanks for your answers...
I'm a bit embarrased.... When you install the debugger It is mandatory to install de openmsx from the repository (version 14). When I start the catapult that I installed It start the default system openmsx (It is to say v14). So the debugger connect to the v14.
I just discovered (testing more posibilities) the problem is not the debugger that I tried to configure. The workaround is configuring catapult to use v16 and after start the debugger.

Once more time thanks....
Best wishes

PS: it work smooth, I have to do more tests but It could be a good environment.

Page 8/8
1 | 2 | 3 | 4 | 5 | 6 | 7 |