Need your opinion regarding GR8NET capabilities

Page 58/58
51 | 52 | 53 | 54 | 55 | 56 | 57 |

By Eugeny_Brychkov

Paragon (1172)

Eugeny_Brychkov's picture

23-02-2020, 22:21

Wlcracks wrote:

But when using a external PSG the joysticks are not working anymore?

Problem is fixed. It was related to, due to special control circuit for PSG in this machine, it has the index register corrupt if another PSG I/O operation had been performed, thus before any reading or writing of the data port the index register must be explicitly (re) loaded.

By Wlcracks

Champion (434)

Wlcracks's picture

23-02-2020, 22:54

Thank you again!

By ToriHino

Hero (655)

ToriHino's picture

04-04-2020, 20:41

Looks like i have now the same problem as AxelStone had:
try to navigate Internet with _NETBROWSE -> Device I/O error

Selecting 'Konami games' does work (and downloads even the roms) but the internet option always gives a Device I/O error. Also the unapi tools no longer work.

I already used the manual update from disk to downgrade back to version 0.9 but no success, still the same problem.

Current versions i have:
Flash: V.0.9 (2019/5/30)
Engine: V.0.9 (2019/5/29)

Any clue what to do about this?

By Eugeny_Brychkov

Paragon (1172)

Eugeny_Brychkov's picture

28-07-2020, 23:29

Releasing GR8NET firmware v.0.12. Notable changes: audio mixer reworked, controls changed to logarithmic, audio dynamic range compression, new commands NETMRESET and NETVARWAVE, boot-up menu has audio and mapper profiler. New version of manual is available on the website.

Feedback is highly desired.

There will be audio volume tuning tool released in some time based on VGMPLAY (will be announced separately).

By enribar

Paragon (1110)

enribar's picture

03-01-2021, 15:02

I finally updated my GR8NET with firmware v.0.12.
At first sight I didn't success in online updating, so I updated with the USB-Blaster device.
When I updated the firmware (update.bin) an error of "different block crc" appeared, but the 2nd attemp succeeded in updating.
The only thing that last is this message displayed during booting:
"Warning: FPGA and flash chip firmware versions mismatch, please update both to the latest"
I ask to Eugeny how to solve this, anyway the cart works good (it seems... but a test with Zanac Ex modded to SCC audio is played as a normal PSG, is that ok?)

By Pencioner

Scribe (1354)

Pencioner's picture

03-01-2021, 15:15

You seem to have updated only FPGA part, but actual firmware consists of two parts - FPGA + MSX BIOS - so if you have network functioning properly, you can update the BIOS online - just skip update FPGA part and only do what you should with the "update.bin" file which is the BIOS

By enribar

Paragon (1110)

enribar's picture

03-01-2021, 15:30

Hi Pencioner, I already updated with "update.bin" and was a success, but that message appears again.

By Pencioner

Scribe (1354)

Pencioner's picture

03-01-2021, 17:20

Maybe your FPGA version is not latest then? The one you flashed via blaster?

By enribar

Paragon (1110)

enribar's picture

03-01-2021, 17:27

I flashed the FPGA's pof file with USB-Blaster and Quartus, and displayed version is 0.12.
Also, the firmware is updated online, downloading update.bin and following the istructions.
I try to repeat the firmware installation, only.
As far as remember, my GR8NET belongs to the 2nd batch produced, the version printed on board is v.3.0.
Despite of the warning message I'm happy because my cart works.
The only thing that isn't working is MSXHub.

Page 58/58
51 | 52 | 53 | 54 | 55 | 56 | 57 |