help needed: Ax-170 acting strange after messing up diy cassette cable

By hconc

Supporter (2)

hconc's picture

13-09-2022, 15:36

Hi,
I just got my AX-170 a few days ago and today i decided to build a cassette cable following the pinout diagram here on this site but i messed up and left a blob on din connector that shorted the pin 4 to GND and hastily connected it to AX-170. The display was all bad so i turned it off immediately and removed the cable. Now computer turns on fine and everything works fine, the default arabic mode is fine but when i boot into english mode the "alphabet keys (some keys ) dont work or work as cursor keys.. if i keep pressing keys they start to work normally again. The arabic basic is fine too (ie getting into basic by pressing 5 in arabic menu). Plus i dont think the cassette port will work either. Perhaps someone here can help guide me to repair. Thanks

Login or register to post comments

By Daemos

Paragon (2009)

Daemos's picture

14-09-2022, 06:40

You propably damaged the msx engine the big chip on the bottom of the mobo. Keyboard and tape port are usually connected unbuffered. You are lucky the msx still boots and does things. The msx engine cannot be replaced unless someone has a broken msx on which this particular msx engine can be salvaged.

By alali.ahmed.t

Expert (105)

alali.ahmed.t's picture

14-09-2022, 17:48

1. Check carefully for any conductive material left over using magnifier or something allow you to see properly and try to clean it properly using alcohol.

2. Check using multimeter the resistors that the joypad connectors are connected to.

3. Check using multimeter the network bussed resistors.

You can do the above checks while the machine is off.

Damaging MSX engine or anther ICs is not easy, I have done a lot of horrible experimentations around Yamaha and Sanyo machines and they are still alive including putting 5V+ together with GND, and the machines still work.

By Wierzbowsky

Guardian (3526)

Wierzbowsky's picture

15-09-2022, 11:55

This one has Toshiba's chip, it may be more vulnerable. In my 30 years of Yamaha MSX usage I've seen only one partially broken MSX engine.

By hconc

Supporter (2)

hconc's picture

16-09-2022, 10:57

Thankyou all for your suggestions. Turns out the keyboard membrane is the culprit it coincidentally started to act up at the same time.I guess the ctrl key is used alot so that’s why its getting stuck. If i repeatedly press it a few times it gets ok. Port turned out to be fine. I have removed the membrane and cleaned it with a bit of ipa but ita still the same. I am in love with MSX systems now, they are simple and reliable and IMHO learning z80 assembly is easier then other 8-bit processors plus the interfaces are simple to work with unlike C64 building a cassette interface was a piece of cake.