Bug in The Lost World

By foody

Champion (452)

foody's picture

07-03-2022, 20:00

When I am fighting the third demon where they opened the coffin and after fighting the two trolloc, after a cutscene it loads and then freezes. Nothing happens after that. The battle scene between me and the demon doesn't commence. I tried copying the files from virtual disk into folder and use MM of megaflash to play it directly on the SD it fails. Wrote the disk image into real disk and tried it there it failed.

Every time after this scene the game freezes after attempting loading the battle...yet the walkthrough continues till the ending of the game. Meaning someone already passed this part. Anyone have a good working disk image that passes this bug. The only thing I didn't do is play the game from virtual disk itself...but I doubt that will make any difference.

Any advise anyone? I have invested a lot into the game and I really want to see it till the end. Any help on this matter will be greatly appreciate it.

Login or register to post comments