Problem booting UZIX image floppy

By Emily82

Resident (46)

Emily82's picture

09-10-2019, 18:37

Hey guys i was trying to boot uzix dsk kernel image on both my NMS8280 with gotek and openmsx emulating the same machine.
In both cases i have kernel boot hanging after some messages.
I tried the older version 1.0 and nothing, uzlo crashes trying to boot drive j

instead emulating msx turbo, uzix image boots up without problems.

Is there some way to boot those floppy images to msx2 computer?

Login or register to post comments

By sdsnatcher73

Prophet (3852)

sdsnatcher73's picture

10-10-2019, 20:10

Hey, so I did some testing on openMSX. It will not boot on any MSX2 with just 128kB (let alone 64kB). If you add a Memory Mapper (512kB/1MB/etc) in openMSX extensions it will continue booting the kernel. I tried it on Philips NMS8245/8250 and Sony HB-F1XD/XDJ/XV. Oddly enough it will not work on an NMS-8250 with internal expansion to 512kB (tested by modifying the machine xml for openMSX)... which probably means it has issues with RAM in subslot somehow...

So getting an external memory mapper (probably 128kB is enough) should allow you to use it on your NMS8280.

By Emily82

Resident (46)

Emily82's picture

11-10-2019, 03:29

It seems some code bug, normal considering its a dead project. Thank you i will try it also to real hardware msx when i get an external memory mapper.

By Manuel

Ascended (19330)

Manuel's picture

11-10-2019, 07:42

As it works with the turboR, it must be something else than an external mapper or RAM in a subslot.

By Emily82

Resident (46)

Emily82's picture

11-10-2019, 18:56

I tested it now on openmsx emulating NMS8280 with 512K external mapper, uzix works.